Login Action Required

The NinevehGL Forum uses a new concept of "socialized forum" or as we like to say "Tweet Forum".

Here is the deal:
  1. No new registration is required. Just sign in with your Twitter account and authorize the NinevehGL Forum.
  2. Once you’re in, you'll be able to "Follow a Thread", that means every time that thread receive a new post or update you'll receive a mention on your twitter.
  3. Besides, you can enable "Auto Share", then every new post and/or thread you make will be tweeted on your timeline. (By default, auto-share is enabled only for your threads)

Forum Rules:

1. We understand human comunication can become "hot" sometimes. So some insults and bad words ARE allowed. Just don't push too much being an asshole all the time.

2. SPAMMERS are not allowed. There are penalties for this kind of user and they can be banned forever.

3. You can report other users, if you judge necessary. An user reported many times by many people can also be banned forever. However you can also receive penalties for report deliberately for no apparent reason.

If there is a similar thread title, make sure the other one doesn't already have the answer you're looking for.

This forum uses the BBCode (Bulletin Board Code), here are some instructions:

Bold: [b]text[/b]
Italic: [i]text[/i]
Underline: [u]text[/u]

Code: [code]text[/code]

[ul] [*]item [/ul]
[ol] [*]item [/ol]



Embed (videos, code, 3D):

Welcome to the NinevehGL's world!
NinevehGL is a 3D engine forged with pure Obj-C.
Welcome to the
Hello, Guest.

Your current vote:

You can change your vote many times. But it's still one single vote.

Problems with New xCode
Vote this thread:

Sat, Oct 26 2013

Hello guys. I went recently to the latest version of xcode. None of my previous projects I was working on Lion (now I maverics) work. I have tried using the default projects directly downloaded from the beta of nineveh .. but in any case they all go always crash. I have always the same problem. What do I do? Can any of you using this framework on maverics? Help
0% like this - 0/0


Posts: 571


Sat, Oct 26 2013

In response to: @Kurama_69_

Use the version which support armv7s and don't include armv64 yet.

0% like this - 0/0

Sat, Oct 26 2013

In response to: @dineybomfim
Hello let me get this straight. Should I download this version, and then install it? Among the various ipad in the simulator which can be used for and what version of iOS? (I can decide whether to compile for ios ios 6 or 7) .. I am not competent with nineveh so excuse me if I ask stupid questions
0% like this - 0/0


Posts: 571


Sun, Oct 27 2013

In response to: @Kurama_69_

Hi buddy,

OK, the point is not about the iOS version nor the device you're trying to run, the point is about the Compiler version.

The new Xcode, (5.1) brings the compiler Apple LLVM 5.0, which by default is ready to compile for Archs armv7, armv7s and armv64 (the new 64-bits Apple Arch).

As NinevehGL is pre-compiled, it already brings pre-compiled architectures. This is why you need to use a NinevehGL version that already support the Arch you're trying to use.

The link I just sent you, has the Archs armv7 and armv7s, but not the armv64. That means you can't run it as a native 64 bits yet.
0% like this - 0/0

Mon, Oct 28 2013

In response to: @dineybomfim

Thanks for the reply. I imagine that you are already working to try to resolve this incompatibility '. However, since it is a problem of the compiler, it means (correct me if I'm wrong) that simply does not support the new ninevhe gls archietettura 64-bit, but still, it can be executed normally even in the last iphone or ipad. Right?
0% like this - 0/0


Posts: 571


Sun, Nov 3 2013

In response to: @Kurama_69_


You're totally right, just as many other libs, like Google Maps, Facebook SDK, AR engines, BarCode reader libs, etc... you can compile for arch armv7s and use it in new 64bits devices, but not directly compile for arch armv64.

All those third-party libs takes some time until migrate their code to a new arch, because it's necessary to make it compile with the new archs without deprecate the old ones, sometimes this is a hard path to follow... this is why libs like Google Maps, prefer to deprecated old arch instead of making a full compatible version.
100% like this - 1/1

NinevehGL is a 3D engine built right on top of OpenGL ES and it uses all the programmable pipeline power, making it easy for you to create great application with shaders.

Share on

Follow NinevehGL
Fastest way to contact us:

Copyright © 2011 db-in. All rights reserved.